Jump to content

Search the Community

Showing results for tags 'beachcomber'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Hot Tubs & Spas
    • Portable Hot Tubs & Spas
    • Inflatable Hot Tubs
  • Inground, Fiberglass and Aboveground Swimming Pools
    • All Swimming Pools Types
  • Swim Spas & Exercise Pools
    • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
  • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
    • Hot Tub Water Chemistry
    • Swimming Pool Water Chemistry

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Location


Interests

Found 5 results

  1. Hey guys, I am looking to buy my first hot tub and am looking or some help. I live in Edmonton and have access to most major Canadian brands/dealers. From word of mouth I have heard mostly good about beachcomber and bad about arctic spa, but have been frustrated trying to find consumer feedback on most spa brands online before finding this forum. I am hoping you guys can give me some experienced feedback which brands best suit what I am looking for. I have been in beachcombers before but really lack exposure to other brands. My first priority is the most reliability you can get from a hot tub in Edmonton's extreme cold and temperature swings. Inside the warranty window and beyond, I don't want a hot tub that is constantly broken down or that will need to be replaced within the next decade. I would like a 6 seater minimum, to seat family and friends but do not want to spend more than $14k CAD on a spa. Jet power and massage aren't super important to me, I just want a spot to relax. So far my favorite is the Beachcomber 590 Hybrid4. I like the simplicity (minimal electronics to fail) and seating layout although it is right up against my budget and I understand the risk the pump location under the steps carries. I have read that the dealer and service provided under warranty is very important and I will be sure to do that research once I can get it narrowed down to a few brands. Thanks for any help!
  2. I'm having an OHH code on my beachcomber hot tub I just replaced the smaller pump as the last one burned out. I filled from the filter housing, opened the bleed screw and drained all the air through there, everything seemed okay last night but when I checked it this morning it was still cold and there was a SNB code I pulled the sensor out (lots of water no air) and also unplugged it and sprayed with electrical contact cleaner Now instead of a SNB code I'm getting the OHH as soon as I turn on the breaker even if it has sat for a few minutes I also tried unplugging the b sensor and there was still an OHH code right away. Maybe needed more time to reset though ? Hoping it's not a circuit board. Don't really wanna keep throwing parts at it. Everything was working fine before the pump burnt out Any help appreciated ! Thanks!
  3. The other day my hot tubs hush pump return split nut collar had broken which caused a water like explosion due to the pressure; after that had happened my hot tub shut off right away. Once the new part was installed I went to flip the breaker for the hot tub only to notice right after flipping it, it trips again. I had gone to the hot tub management system and unplugged the pumps one by one to find that it did not trip with hush pump disconnected, now the hush pump was fine and working up until this point, also which nothing had happened to it other than the split nut break. Model number is 750E
  4. Hofully someone can point me in the right direction here... I have a recently acquired a 2003 550X spa and was aware that there was, and still is, an issue where it shuts down and reads 'OH'. There doesn't seem to be much of a pattern to this occurring but its fair to extremely consistent. Initially the spa heats up to anywhere around 34 with no issue at all, then cuts out. Re-sets straight away and continues to heat a little more (display set to 38). I can get the spa to full temp by resetting each time but then it seems to shut down more frequently. I initially replaced the hush pump - This was needed for more than one reason. I believe the original owner tried replacing both temp sensors. And I have checked for air blockages and the filter is new. Any help with what to try next would be much appreciated! One thought... can I test or possibly clean the flow switch easily? Is that worth trying?
  5. hi I have a 14 year old beachcomber 550x - the underwater light no longer works. I drained the tub and when removing the lens cap, found that the housing unit threads to hold the cap in place are no more (cap threads are fine) . It is also possible that the housing may have been leaking due to the thread issue, as I had a leak as well. I believe its a standard 3 1/2 or 2 1/2 housing with a 12 volt bulb driven by the balboa pack. what are my options here? - are there any diy steps to replacing the housing - I understand I may need to get to it from underneath, but not sure....or is it possible to silicone the cap back in and eliminate any potential for leaks? thanks
×
×
  • Create New...