Jump to content

Search the Community

Showing results for tags 'Prodigy'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Hot Tubs & Spas
    • Portable Hot Tubs & Spas
    • Inflatable Hot Tubs
  • Inground, Fiberglass and Aboveground Swimming Pools
    • All Swimming Pools Types
  • Swim Spas & Exercise Pools
    • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
  • Swim Spas & Exercise Pools
  • Pool/Spa Water Care
    • Hot Tub Water Chemistry
    • Swimming Pool Water Chemistry

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


Location


Interests

Found 8 results

  1. Hi new to this forum. Last week i replaced the leaking circ pump , refilled tub and powered on. Pump works fine and doesn't leak anymore ....however nothing else does. Control panel looks to be not working...screen trying to display over time but nothing works on buttons...thought it was locked but the unlock procedure doesn't seem top make a difference either. Panel display was looking a little ropey before hand...not sure if its damp inside or note. Searching on the internet looks like the panel can't be obtained anymore....any suggestions....i dont really want to get ri
  2. I am on my 3rd main board for my Prodigy Hot Tub, it happens every time we unplug the hot tub to drain, clean and refill. As soon as we plug the hot tub back in we get the Green and Red lights blinking and she doesn't heat up but still circulates. Yesterday is the third time, the power went out from a storm and when she kicked back in the lights were blinking on the hot tub again. I unplugged it for a few minutes and plugged her back in and still blinking lights. We enjoy it between refills but not enjoying the expense of these boards. Any ideas on whats causing this?
  3. Hello, Need a little help, please. I changed out the water yesterday on my Hot Springs Spa (the Prodigy model purchased February 2005) and nothing is showing up on the temperature gauge. It was working perfectly before I changed the water. When I turned the power back on after changing the water (first the 20 AMp and then the 30 AMP -- can't remember which one was first but I tried it both ways) the temperature gauge came on for about half a minute and then went blank. When I press the plus or minus button to see the temperature, nothing appears. The heater is working though and the water hea
  4. I purchased a used Hot Springs Prodigy H hot tub. They originally had it wired using the 115 VAC wiring. When I installed it I went ahead and converted the tub to the 220 VAC converted Spa wiring. I did everything as described. Used 8-3 wire from the panel to the sub panel (55ft). then 10-2 and 12-2 wire from the two (30A & 20A) GFCI breakers in the sub panel to the hot tub (8ft). All wires are sealed in the liquid tight casing and fittings. I removed the jumpers on the Terminal block and installed one at the 4 & 5 locations and installed the program jumpers in locations 1, 2, 3
  5. Hello. I have a 2002 Hotspring Spa Prodigy that was in perfect working order. Yesterday I turned on the clean cycle and noticed a trickle of water coming out of the vent located at the bottom of the tub in the front corner on the left side of the tub (where the circular hole with wire mesh is). The leak can be varied in flow by adjusting the jet selector dial. The main compartment where the heater and controls are is dry but I noticed the black 3-way connector (with 2x 3/4" tubes and 1x 1/8" tube) has a little water in the vertical 3/4" tube and the 3/4" horizontal tube. Can anyone tell me w
  6. Hello all, this is my first post to this forum. Have a bit of a problem. My wife and I have a 2005 Hot Springs Prodigy (Model H) hot tub that has been working great for almost 2 years. Recently I started hearing a clicking noise coming from within the components compartment. At the same time our tub wasn't hot anymore, but only warm. The circulation pump and jets were working fine at that time. I opened the IQ2020 panel and heard the clicking coming from the heater board. I noticed that the white heater wire also was darkened, like it had shorted out and fried the wire & board. I did som
  7. Looking at a used 2003 Hotsprings Prodigy for $3500 vs new 2012 Jetsetter or Limelight for almost double that ($6600/$6000). All are from a reputable dealer. The used Prodigy was (reportedly) well taken care of; owner traded for new smaller HS tub when moving from large home to a townhome. It comes with 1 year warranty. I'd like a 7 - 10 year life for the tub. Thoughts?
  8. Hi All. I live in the NY metropolitan area. Received these prices from dealer: Aria: $10,695 (ozone, steps, cover, sub-panel, free delivery, in home orientation) and a $100 and he'll "throw in" a lift (although didn't say which kind). Prodigy: $6895 (ozone, steps, cover, sub-panel, free delivery, in home orientation) and $290 he'll throw in a lift. What's your "take" on these prices? These are dealer's first offers. I haven't countered. Of course, he said at the outset that "it's the best he can do". Incidentally, you folks have any preferences with the cover lifts? Which ones and why?
×
×
  • Create New...