Jump to content

nizman

Members
  • Posts

    2
  • Joined

  • Last visited

nizman's Achievements

Newbie

Newbie (1/5)

0

Reputation

  1. Thanks for the reply. But I think we have it figured out. It seems that the culprit may indeed be my water. I got with a neighbor whose well water is much better than mine and used his water to fill my tub. I've been using it for the past two weeks with no issues whatsoever. With my water, the chlorine levels (using the Frog system) were all over the place - they seemed low all the time and I was adding chlorine to compensate. With the neighbor's water, the balance is stable and the chlorine levels seem more controlled. In fairness, it took two weeks of using my water to notice a problem so this next week will be the true test. But if I don't come back here looking for further advise, assume my bad water was the problem. Thanks.
  2. We just took delivery two weeks ago of a brand new Bullfrog R8 to replace our 16 year old Hot Springs Prodigy that died last year (yes, it took a year to get the new tub!). We ran bromine in the Prodigy for the first 3 years with no issues when I suddenly developed an itch on my legs after using the tub. No one else in the family had any issues. There was no rash or redness associated with it - just a nasty itch that would begin about 2 hours after I would get done with a soak and would last for a day or so. After consulting with my dealer and a year of trying a bunch of things, we finally settled on a switch to Baqua Spa. While it solved my itch problem, I hate the product. It has a rather unpleasant smell and if breathed while the jets are on, it burns your lungs. Nevertheless, I was a (somewhat) happy soaker for the remainder of my Prodigy’s life. When we bought the Bullfrog, I told the dealer of my bromine concerns. They said that the Bullfrog’s special chlorine cartridge system was way gentler on the skin and that I shouldn’t have any issues. And for the first two weeks, this was true. However, now my itch is back and with a vengeance. This time, my legs were fine, just the area between the legs (if you know what I mean). Woke me up in the middle of the night and I couldn’t get back to sleep. I took a water sample to my dealer and they said my chlorine levels were low and to add some granular chlorine. I did that, tested the water and the balance and chlorine levels looked fine. Waited 24 hours just in case. Took a 30 minute soak and came out feeling fine. Woke up at 2am with my entire body itching - back, legs, and between the legs, which was even worse than before. I’ve been reading many posts here of itch issues, but many seem to also result in some form of rash - I don’t get that. Also, as mentioned, I’m the only one of six in the family that seems to be having this issue. I can swim in chlorinated pools, even public pools that reek of chlorine, with no problem, which makes me think it’s something local to me. I really would like to avoid going back to Baqua Spa if I can avoid it. While I’m sure the issue could be anything, I have one other thing that may make my situation unique. I’m on a well and our water is nasty. I can’t use the water direct from the well - I have to use my softened water and add calcium when the tub is full. My TDS with a fresh fill STARTS at 1500 so I have to change water often. Is it possible that the chlorine is reacting with something in my water? I’m looking into having water delivered but don’t want to spend the money if it won’t make a difference. Any other suggestions are welcome. Thanks, Nizman
×
×
  • Create New...