Jump to content

jesseleonard

Members
  • Posts

    6
  • Joined

  • Last visited

jesseleonard's Achievements

Newbie

Newbie (1/5)

0

Reputation

  1. theres a little slot in the top i just took a flat head screw driver in there and popped it off
  2. so how do i take jets off? i have a hotspot sx from 2018. i tried unscrewing them and they wont come off i dont want to break them
  3. Yea, thoes pictures were perfect thank you! if i figure out anything about why only some of the jets are working ill be sure to share with you, i also noticed some of the jets on the captains seat are actually taking in water and only 1 jet is really pushing water. have you done anything to try and trouble shot that problem?
  4. Hello. I have the same spa! I just bought it used and had the same problem. In my case it was the back side of the impeller. The shaft had essentially exploded. 60$ and about an hour of tinkering and it was fixed. unfortunately the tub has to be drained for the pump to be pulled but you can be up and running in 24 hours. quick unrelated question for you if you dont mind. I have a hotspot sx. I was wondering if you could post pictures of the plumbing behind the access panel? Mainly on the left hand side. only half the jets are working, and only one of the intakes feel like they are pulling water. When i look inside i find there is a hose that is cut and capped. I am thinking someone was in there and did a quick fix to make it work but not a proper one. Any information would be helpful as I cannot find a plumbing schematic anywhere.. pictures to the left side of the heater where the thick white hoses go to and from and the smaller hoses with the blue arrow stickers on them
  5. Hello. I have a hotspot sx. I was wondering if someone that has one could post pictures of the plumbing behind the access panel. Mainly on the left hand side. I bought mine used and only half the jets are working, When I look inside I find there is a hose that is cut and capped. I am thinking someone was in there and did a quick fix to make it work but not a proper one. Any information would be helpful as I cannot find a plumbing schematic anywhere..
  6. Hello. I have a hotspot sx. It looks like the same tub you have and I was wondering if you could post pictures of the plumbing behind the access panel? Mainly on the left hand side. I bought mine used and only half the jets are working, When i look inside i find there is a hose that is cut and capped. I am thinking someone was in there and did a quick fix to make it work but not a proper one. Any information would be helpful as I cannot find a plumbing schematic anywhere..
×
×
  • Create New...