Jump to content

happyfish

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About happyfish

  • Rank
    Newbie
  1. I sent mail through the tidal fit website when I had a question my dealer couldn't answer. Maybe you could try that? https://tidalfit.com/the-exercise-pool/contact/ --jodi
  2. Hello, first time here. We have had a Tidal Fit EP-14 since October and we keep getting an error message that the heater is dry. When this occurs, I note that the filter seems to be clogged with a sort of sticky blue goo. We are using an ozonator and granulated chlorine, ph down when needed (almost never) and ph up and baking soda to adjust the ph higher and the total alkalinity respectively. Our dealer also suggested we use EZ Pool, one scoop every 4 days. We did so, and our water was quite clear. However, even though we cleaned our filters ever few weeks, we noticed that we would get that error message and the blue goo in the filter. Taking the filter out cures the heater dry problem. We got new filters and the same thing happened after a week and a half. We just bought yet another set of filters and emptied our spa. I am worried about using the EZ Pool again if it could be the cause of our problem. I told our dealer and he suggested we switch to AquaFinesse. I am frankly unclear on what either the EZ Pool of the Aqua FInesse do and if they are needed at all. Any advice? Do we just need to clean our filter more often before the goo develops? What the heck is the goo? We also noticed a little purple sediment in the past week before we drained it. Thanks in advance for any help! --jodi
×
×
  • Create New...