94 Tiger River Manora Wont Heat - Portable Hot Tubs & Spas - Pool and Spa Forum

Jump to content


(July 17, 2014) POOLSPAFORUM.COM SITE UPGRADE!


Photo
- - - - -

94 Tiger River Manora Wont Heat


  • Please log in to reply
1 reply to this topic

#1 jwbenninger

jwbenninger

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 15 November 2012 - 10:28 AM

I drained my Tiger River Manora S/N M-240627 last spring to fix a leak and left it drained all summer. When I went to fill it back up this fall I couldnt get it to heat. I found that there was pretty significant corrosion on the heating elements so I replaced the heater. Still no luck. I traced the wiring out. The heater is wired between two relays soldered into the circuit board. The heater is getting power on one side but the relay (what I assume closes to complete the circuit) is not working. I can jump the wire straight to the neutral wire comming from the GFI and the heater will work fine. Does anyone know what these relays control? Can I just change the relay, or test it? Any help would be greatly appreciated. Thanks, Jim

#2 PreservedSwine

PreservedSwine

    Spa Guru

  • Members
  • PipPipPipPipPip
  • 1,079 posts
  • Gender:Male
  • Location:Fort Myers, Fl

Posted 15 November 2012 - 03:33 PM

Before you do that- ensure the relay that supplies power (the one of the right) opens and closes properly as you turn the heater on/off. You could skip the neutral interlock relay (the one on the left), but you're losing redundant protection in case the other relay fails.

Are you certain the heater relay is opening and closing properly, and it's only the neutral relay that's failed?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

website security