Jandy Aqualink Rs4 All Button Problems - All Swimming Pools Types - Pool and Spa Forum

Jump to content


(July 17, 2014) POOLSPAFORUM.COM SITE UPGRADE!


Photo

Jandy Aqualink Rs4 All Button Problems


  • Please log in to reply
2 replies to this topic

#1 JZ510

JZ510

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 29 March 2010 - 06:44 PM

Need help to diagnose what the problem is with my Jandy Aqualink RS4 Control panels (indoor and outdoor). I had replaced a pool/spa value that wasn't working. I cut the power line for the value to the box. Then I replaced the value and connect the new power line to the outdoor panel box. I didn't touch the main power lines going into the box. I then noticed that the outdoors control panel didn't work. And check the indoors panel and that didn't work either. I pushed the reset buttons and still nothing is working. I know the the power is working becuase I have another pump connected to the outdoor box that works. So there is power. But the panels are not working? Is there another reset button? Or a circuit? Did I fry the circuit box?

#2 Pool Clown

Pool Clown

    Spa Guru

  • Members
  • PipPipPipPipPip
  • 2,655 posts
  • Gender:Male

Posted 29 March 2010 - 07:18 PM

The Jandy RS's board has a fuse on it that will blow if the power cable that runs to the valve actuator(s) gets shorted for any reason. This includes a valve actuator that shorts out internally (quits working). Or if you didn't power down the RS before you cut the valve actuator wire, then that could be what happened to you.

Factory Warranty/Service for:
Jandy, Pentair, Sta-Rite, Raypak, Polaris,
and Paramount pool cleaning systems.


#3 jughead

jughead

    Junior Member

  • Members
  • PipPip
  • 39 posts

Posted 30 March 2010 - 04:49 AM

also if you just cut that actuator wire instead of unplugging it you probably didnt check to see if the actuator was the problem . odds are it was but in the future you should plug in the other actuator ( whether it be suction or return ) that is working into the one that is not to see if it works . if it doesnt then your board could be bad .




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

website security