Tiger River-bengal Spa (how Do I Tblsht A No Heat Problem)? - Portable Hot Tubs & Spas - Pool and Spa Forum

Jump to content


(July 17, 2014) POOLSPAFORUM.COM SITE UPGRADE!


Photo
- - - - -

Tiger River-bengal Spa (how Do I Tblsht A No Heat Problem)?


  • Please log in to reply
1 reply to this topic

#1 fachabrut

fachabrut

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 08 May 2008 - 09:25 PM

I have a 5 year old Tiger River Bengal model hot tub. Everythings seems to be working ok except the water is not getting heated. I checked the heater reset switch was wasn't tripped. Any idea on how to determine if it's the heater itself? I'm fairly technical and have a voltmeter available if that can aid in troubleshooting. Thanks.

#2 Dan.The.Spa.Man

Dan.The.Spa.Man

    Spa Guru

  • Members
  • PipPipPipPipPip
  • 694 posts

Posted 09 May 2008 - 03:03 AM

QUOTE(fachabrut @ May 9 2008, 01:25 AM) <{POST_SNAPBACK}>
I have a 5 year old Tiger River Bengal model hot tub. Everythings seems to be working ok except the water is not getting heated. I checked the heater reset switch was wasn't tripped. Any idea on how to determine if it's the heater itself? I'm fairly technical and have a voltmeter available if that can aid in troubleshooting. Thanks.


Turn power off to the tub

Open the IQ2020 control box

The heater wires enter the box all the way to the left side. Take all three wires off from the board.

Set your meter for OHMS (upside down horseshoe) and you should get a reading of anywhere from 9.0-14.0 depending on the heater. If it reads O.L. or zero then the heater is bad.

If the heater checks out good, turn power back on with the heater still disconnected, with your meter set for AC voltage, carefully test the terminals from the board that you took the black and white wires off from. You should get either 110v or 220v depending on how your tub is set up. If you don't get this voltage then that whole left side relay board needs to be replaced.

Turn power back off before you reconnect the heater wires.

Good luck.

I have a few extra HotSpring heater relay boards for tubs from 2001-2008 if anyone is looking for one cheap. Part #77119




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

website security