• Announcements

    • webmaster

      Missing Posts   09/21/2016

      We are aware some posts are missing. This is due to our server upgrade. You will need to re-create any posts you have made that are missing. Thank you for your understanding on this matter.
Sign in to follow this  
Followers 0
jd4010

Circulation Pump / Ozonator Stops Running

3 posts in this topic

Greetings.

I have a Master Spa Twilight 7.2 that is just 6 months old. The circulation pump (with ozonenator) used to run 7x24 and it kept the water crystal clear but recently we are seeing that it is shutting off and doesn't start unless we change a setting like the temp and then from there, it will kick on for a bit and then turn off. Because of this, my water is not as clean/pure as it used to be.

I called Master Spa who advised me to contact my seller. Seller setup a service call but for July 20th (ouch!). In the meantime, we've power cycled the unit, waited for hours before restarting it, changed the settings from Standard to Econ to Sleep, changed temps....but it still runs for just a short time then turns off.

Any thoughts/ideas? I don't believe it is a pump issue as the primary, secondary and circulation pumps work fine. I'm suspecting a circuit board issue of sorts but just wanted to see if anyone else had any tricks.

Take care.

Share this post


Link to post
Share on other sites

Sure sounds like a programming issue to me. Owner's manual any help?

B)

Share this post


Link to post
Share on other sites

Mine started doing the same thing about 2 weeks ago. Sometimes I check and its running but usually not. It runs about 2 minutes after the oner of the big pumps runs and then stops. Same spa Twilight 7.2. I've had mine for 9 months, had Pump 1 replaced about a month ago. It just seized up and stopped running. Otherwise no other issues. I was wondering about a programming issue, since the pump seems to work fine when its on. I have tried the same things as you, JD 4010, and nothing seems to work. I guess I'll call the repair shop tomorrow and post back when I find out what's wrong.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0