• Announcements

    • webmaster

      Missing Posts   09/21/2016

      We are aware some posts are missing. This is due to our server upgrade. You will need to re-create any posts you have made that are missing. Thank you for your understanding on this matter.
Sign in to follow this  
Followers 0
Paul_SF

Tiny Bubbles From The Hot Water Return - Is This A Problem?

5 posts in this topic

Hi all:

I have a Sundance hot tub. Over the last month, I noticed that the hot water return jet is jetting out a lot of tiny air bubbles. It never used to do that before.

I changed water and the filters today and it still does the same thing.

Do I have a problem? Is it a chemical thing? or do I have a leak? Is air getting into the plumbing/pipes for the water heating system?

Thanks you so much in advance!

Paul

Share this post


Link to post
Share on other sites
Hi all:

I have a Sundance hot tub. Over the last month, I noticed that the hot water return jet is jetting out a lot of tiny air bubbles. It never used to do that before.

I changed water and the filters today and it still does the same thing.

Do I have a problem? Is it a chemical thing? or do I have a leak? Is air getting into the plumbing/pipes for the water heating system?

Thanks you so much in advance!

Paul

Is you tub equipped with an Ozone generator?

Share this post


Link to post
Share on other sites
Is you tub equipped with an Ozone generator?

I don't know. How do I check whether it has an ozone generator?

This is an existing hot tub in a house I bought two years ago. I never noticed the tiny bubbles until when I started about a month ago...

Paul

Share this post


Link to post
Share on other sites
Did you hit the tub like the Fonz and say, "aehhhhh"?

That could've triggered something.

What year is your Sundance? Earlier models that do not have a drain on the floor should have bubbles comming from the return jet if there was ever an ozonator installed. If you didn't have bubbles before and do now, you may have had a bad check valve that has either started working again or the tubing may have come loose. Either way, you should open your equipment bay doors and check to see if you do indeed have an ozonator and that all the tubes are still attached. Ozonators come in all sizes and shapes but there should be 1/4" - 3/8" clear plastic tubing comming from it to an injector in the return plumbing of the spa.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0