• Announcements

    • webmaster

      Missing Posts   09/21/2016

      We are aware some posts are missing. This is due to our server upgrade. You will need to re-create any posts you have made that are missing. Thank you for your understanding on this matter.
Sign in to follow this  
Followers 0
kellibarr

Infinity Sun Peak Spa - I Have No Manual So Need Help To Get My Spa To Heat

6 posts in this topic

Hi everyone. I received my hottub the other day, from costco. The hottub seems real nice but it came with nothing, missing the manual, filter cartridge, filter lid, head cushions, etc. So I am wondering why it keep going back to the SL mode and it won't heat past 87 degrees. I have pushed all the different buttons and have the heat set to 104 but it won't heat that high, also I see there are modes like F2, F4, F6, F8 but it always goes back to SL and the heat is never on. How do I get it to work properly or is there a problem within the spa? I would appreciate any help out there!! It is waiting to be used but it is just not heating properly.

Share this post


Link to post
Share on other sites
Hi everyone. I received my hottub the other day, from costco. The hottub seems real nice but it came with nothing, missing the manual, filter cartridge, filter lid, head cushions, etc. So I am wondering why it keep going back to the SL mode and it won't heat past 87 degrees. I have pushed all the different buttons and have the heat set to 104 but it won't heat that high, also I see there are modes like F2, F4, F6, F8 but it always goes back to SL and the heat is never on. How do I get it to work properly or is there a problem within the spa? I would appreciate any help out there!! It is waiting to be used but it is just not heating properly.

The tub has 3 modes:

EC = economy - water only heats during filter cycles

SL = sleep - keeps low heat for freeze protection

ST = standard - keeps full temp at all times

To change between the 3 modes, press the temp button and then the light button.

Filtration cycles - the spa filters every 12 hours

F2 - F8 - how many hours the spa filters per cycle (ie. F2 = spa filters for 2 hours every 12 hours)

To change filtration cycles, press the temp button then the jets button closest to the display screen.

Hope this helps. Also hope that Infinity is responsive about getting you the things that didn't show up with the spa. Not a great way to start out! Good luck.

Sandi

Share this post


Link to post
Share on other sites
Hi everyone. I received my hottub the other day, from costco. The hottub seems real nice but it came with nothing, missing the manual, filter cartridge, filter lid, head cushions, etc. So I am wondering why it keep going back to the SL mode and it won't heat past 87 degrees. I have pushed all the different buttons and have the heat set to 104 but it won't heat that high, also I see there are modes like F2, F4, F6, F8 but it always goes back to SL and the heat is never on. How do I get it to work properly or is there a problem within the spa? I would appreciate any help out there!! It is waiting to be used but it is just not heating properly.

The Infinity Sun Peak uses a Balboa M-7 SUV pack and a quick reference guide can be found at the link here.

Also, the owner's manual can be found on Infinity's web-site here

In SL mode, it will only heat the spa to within 20 degrees of the set temperature during filtration cycles.

To heat your spa up, I'd first recommend changing to Standard mode as per Sandi's instructions in the previous post. With the cover on, the spa should heat up about 7 degrees per hour.

Good luck with your spa.

Ken

Share this post


Link to post
Share on other sites

As it no doubt says in your manual linked above, after you select the mode you want you may have to confirm it by pressing a pump button. I have to do that with the Balboa VS system in my new Costco 3 person spa.

Mike

Share this post


Link to post
Share on other sites
Hi everyone. I received my hottub the other day, from costco. The hottub seems real nice but it came with nothing, missing the manual, filter cartridge, filter lid, head cushions, etc. So I am wondering why it keep going back to the SL mode and it won't heat past 87 degrees. I have pushed all the different buttons and have the heat set to 104 but it won't heat that high, also I see there are modes like F2, F4, F6, F8 but it always goes back to SL and the heat is never on. How do I get it to work properly or is there a problem within the spa? I would appreciate any help out there!! It is waiting to be used but it is just not heating properly.

Just curious, our Sun Peak is scheduled to be delivered Thursday around 7:00PM. Did you ask the drivers to place your hot tub where you wanted it or did they just drop it at curbside? If they moved it for you, how much did you pay them?

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0